Bulletins


BulletinBulletin dateReplacement BulletinItem no.SummaryAdded
ENGINE AND ENGINE COOLING - ENGINE
PI-0269A05/01/201110038684Ready06/27/2011
PI-0269A05/01/201110038684Gm: check engine light is on with a stored trouble code. *rm06/27/2011
PB-1028702/01/201110038598Gm service campaign: see document search button for owner letter. in certain driving conditions or if it's been a while between oil changes, the timing chain could wear prematurely and cause the engine light to turn on. *rm06/22/2011
PB-1028702/01/201110038598Ready06/22/2011
PI-0090B03/01/201110038345Gm: there may be an intermittent engine hesitation or flutter. the camshaft sensor terminals likely have poor connections. *rm06/15/2011
PI-0090B03/01/201110038345Ready06/15/2011
08-06-01-011H02/01/201110038261Gm: check engine light is on with multiple trouble codes present. *rm06/14/2011
08-06-01-011H02/01/201110038261Ready06/14/2011
PIT-502809/01/201010036324Pontiac/saturn/buick/gmc/chevrolet/cadillac/hummer: vehicle start and stalls after theft deterrent module replacement. model years 2006-2011. does not apply to vehicles with keyless access system. *pe03/14/2011

Consumer Complaints


Fail datemilesoccurencesPurchase date
ENGINE AND ENGINE COOLING
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
05/14/2010
 1st. my wife was pulling out of a parking spot and had to stop quickly, then when she proceeded to leave again by letting off the brake - the car rolled forward on a slight incline and hit the car parked next to her. when she removed her foot to the gas - nothing she could do to prevent this incident. 2nd. while in the drive position on a hill at a stop sign or traffic signal, i removed my foot from the brake. the vehicle began to roll back almost hitting the vehicle behind me. we further tested the vehicle on various hills/inclines both in drive and reverse and it continued to roll in the opposite direction of the engaged gear. apparently, this is a characteristic of the automatic transmission on this vehicle, the service consultant at courtesy chevrolet of orlando, said this is a flaw in the power train and theirs no known fix. he advised us not to drive it to the mountains if it were him. since our suv is for my vacations and primary use, we are very concerned for our safety. we can't afford another vehicle since we had saved up for the down payment for this car. i saw there are a lot of complains of the same case, it was mentioned until someone dies and/or the family files a lawsuit - no recall or action will be done to fix this! please help in address this issue. i set up a facebook page to address this concern: http://www.facebook.com/chevytraversedeathtrap
09/29/201140000
 The entire engine failed,seized. had it towed to the dealership, they reported that it was do to no oil in the engine. the change oil light was on but not a low oil light, there was no oil leakage or smell noted. the car had been acting odd for 10 days or so, losing power and making a diesel engine sound while running.
06/13/201198231
 Approximately a week after taking it to dealership for diagnostic check on steering problems, my truck started making noise. i took it to several mechanics and they all seem to think it was related to the timing chain. as time progressed the noise got exceedingly worse and used an extensive amount of gas. my car is currently not operating and it has approximately 120k miles. i contacted gm and they stated the problem occurred due to the amount of usage. after checking the website www.chevytraverseforum.com i discovered that many other consumers experienced the same problem; however, their usage was much lower, i.e. 19k posted by cotton-smith, 20k heather and mark, 21k judih, to name a few. sensor code was p0017 i contacted the gm consumer line listed on their website to no avail. requesting an investigation be conducted on the issues relating to timing chains/engine problems.
09/29/201140000
 The entire engine failed,seized. had it towed to the dealership, they reported that it was do to no oil in the engine. the change oil light was on but not a low oil light, there was no oil leakage or smell noted. the car had been acting odd for 10 days or so, losing power and making a diesel engine sound while running.
06/13/201198231
 Approximately a week after taking it to dealership for diagnostic check on steering problems, my truck started making noise. i took it to several mechanics and they all seem to think it was related to the timing chain. as time progressed the noise got exceedingly worse and used an extensive amount of gas. my car is currently not operating and it has approximately 120k miles. i contacted gm and they stated the problem occurred due to the amount of usage. after checking the website www.chevytraverseforum.com i discovered that many other consumers experienced the same problem; however, their usage was much lower, i.e. 19k posted by cotton-smith, 20k heather and mark, 21k judih, to name a few. sensor code was p0017 i contacted the gm consumer line listed on their website to no avail. requesting an investigation be conducted on the issues relating to timing chains/engine problems.
09/29/201140000
 The entire engine failed,seized. had it towed to the dealership, they reported that it was do to no oil in the engine. the change oil light was on but not a low oil light, there was no oil leakage or smell noted. the car had been acting odd for 10 days or so, losing power and making a diesel engine sound while running.
06/13/201198231
 Approximately a week after taking it to dealership for diagnostic check on steering problems, my truck started making noise. i took it to several mechanics and they all seem to think it was related to the timing chain. as time progressed the noise got exceedingly worse and used an extensive amount of gas. my car is currently not operating and it has approximately 120k miles. i contacted gm and they stated the problem occurred due to the amount of usage. after checking the website www.chevytraverseforum.com i discovered that many other consumers experienced the same problem; however, their usage was much lower, i.e. 19k posted by cotton-smith, 20k heather and mark, 21k judih, to name a few. sensor code was p0017 i contacted the gm consumer line listed on their website to no avail. requesting an investigation be conducted on the issues relating to timing chains/engine problems.
09/29/201140000
 The entire engine failed,seized. had it towed to the dealership, they reported that it was do to no oil in the engine. the change oil light was on but not a low oil light, there was no oil leakage or smell noted. the car had been acting odd for 10 days or so, losing power and making a diesel engine sound while running.
06/13/201198231
 Approximately a week after taking it to dealership for diagnostic check on steering problems, my truck started making noise. i took it to several mechanics and they all seem to think it was related to the timing chain. as time progressed the noise got exceedingly worse and used an extensive amount of gas. my car is currently not operating and it has approximately 120k miles. i contacted gm and they stated the problem occurred due to the amount of usage. after checking the website www.chevytraverseforum.com i discovered that many other consumers experienced the same problem; however, their usage was much lower, i.e. 19k posted by cotton-smith, 20k heather and mark, 21k judih, to name a few. sensor code was p0017 i contacted the gm consumer line listed on their website to no avail. requesting an investigation be conducted on the issues relating to timing chains/engine problems.
09/23/201138566
 As i was driving going approximately 55 mph the park assist message appeared on the dashboard and then the car suddenly lost power. the gauges went to 0 and the radio and air conditioning went off. it then suddenly popped back on and 4 different warning lights came on on the dash (check engine, tire pressure, a decal with a lock and the passenger air bag light) and then off again. i pulled over and turned the engine off. when i attempted to start the car again it would not turn over. i attempted 2 times and on the 3rd time the engine turned over and the warning lights were off. the following codes came up when a computer diagnostic tool was plugged in approximately 30 minutes after the issue occurred. b2aaa, b2a00, p0008, po202 and u25e5.
09/23/201138566
 As i was driving going approximately 55 mph the park assist message appeared on the dashboard and then the car suddenly lost power. the gauges went to 0 and the radio and air conditioning went off. it then suddenly popped back on and 4 different warning lights came on on the dash (check engine, tire pressure, a decal with a lock and the passenger air bag light) and then off again. i pulled over and turned the engine off. when i attempted to start the car again it would not turn over. i attempted 2 times and on the 3rd time the engine turned over and the warning lights were off. the following codes came up when a computer diagnostic tool was plugged in approximately 30 minutes after the issue occurred. b2aaa, b2a00, p0008, po202 and u25e5.
09/23/201138566
 As i was driving going approximately 55 mph the park assist message appeared on the dashboard and then the car suddenly lost power. the gauges went to 0 and the radio and air conditioning went off. it then suddenly popped back on and 4 different warning lights came on on the dash (check engine, tire pressure, a decal with a lock and the passenger air bag light) and then off again. i pulled over and turned the engine off. when i attempted to start the car again it would not turn over. i attempted 2 times and on the 3rd time the engine turned over and the warning lights were off. the following codes came up when a computer diagnostic tool was plugged in approximately 30 minutes after the issue occurred. b2aaa, b2a00, p0008, po202 and u25e5.
09/23/201138566
 As i was driving going approximately 55 mph the park assist message appeared on the dashboard and then the car suddenly lost power. the gauges went to 0 and the radio and air conditioning went off. it then suddenly popped back on and 4 different warning lights came on on the dash (check engine, tire pressure, a decal with a lock and the passenger air bag light) and then off again. i pulled over and turned the engine off. when i attempted to start the car again it would not turn over. i attempted 2 times and on the 3rd time the engine turned over and the warning lights were off. the following codes came up when a computer diagnostic tool was plugged in approximately 30 minutes after the issue occurred. b2aaa, b2a00, p0008, po202 and u25e5.
08/25/201125226
 Vehicle seems to hesitate also stalling while at highway speed trying to accelerate to pass (feels like a miss in the engine) rpm drop about 500 - 700 rpms when this happens. it also feels like the torque converter lockup is engaging and disengaging not sure if the new transmissions have that anymore. have taken the vehicle to the dealership and they were unable to find any problems. the dealership last month reprogrammed the transmission to eliminate the hard shifting problem with a bulletin issued from chevrolet .
08/25/201125226
 Vehicle seems to hesitate also stalling while at highway speed trying to accelerate to pass (feels like a miss in the engine) rpm drop about 500 - 700 rpms when this happens. it also feels like the torque converter lockup is engaging and disengaging not sure if the new transmissions have that anymore. have taken the vehicle to the dealership and they were unable to find any problems. the dealership last month reprogrammed the transmission to eliminate the hard shifting problem with a bulletin issued from chevrolet .
08/25/201125226
 Vehicle seems to hesitate also stalling while at highway speed trying to accelerate to pass (feels like a miss in the engine) rpm drop about 500 - 700 rpms when this happens. it also feels like the torque converter lockup is engaging and disengaging not sure if the new transmissions have that anymore. have taken the vehicle to the dealership and they were unable to find any problems. the dealership last month reprogrammed the transmission to eliminate the hard shifting problem with a bulletin issued from chevrolet .
ENGINE AND ENGINE COOLING - ENGINE
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.
03/07/201132600
 2009 traverse purchased 4/30/2009. from the start it had a check engine light on but no symptoms of failure. we took it to dealer 1 on 9/02/2010, with 22,753 miles. they replaced wiring under engine plenum to #1 ignition coils. a couple of days later, the check engine light came back on. at this time the car started to lose power on the freeway sometimes. we took it to dealer 2 on 10/11/2010, they had to get parts and did a temporary fix. we brought it back on 11/1/2010, with 24,656 miles on it and they supposedly fixed it. they replaced connectors in the junction box, saying it was an electrical problem. the light was back on within a few days, and the car was still losing power. we took it to dealer 3 on 2/09/2011, with 30,287 miles for check engine light, and loss of power. they replaced ecm and all 6 coils. the day we left the shop, the light was back on and within a day the car was losing power again. back to the shop on 2/17/11. this time they replaced the catalytic converter. the day after we left the shop the light was back on. they told us it needed a small adjustment and to bring it back on 3/05/11. we went to the shop and the mechanic did not know how to fix it. after being there for a few hours and calling chevy 800 #, they told us to come back next week. on 3/06/11, the car was losing power so bad that we wanted to take it back to the shop, but they were closed. on 3/07/11 the traverse started losing power, and then died. it lost all power and the brakes failed as a result. we had to slam on the emergency brake to not have an accident, and were lucky to not be rear ended. the car has been at the shop the week of 3/07/11-3/11/11. they told us the car is misfiring on all cylinders and dumping raw gas into the exhaust. on 3/11/11 they called to state that they are replacing the catalytic converter (again) and the module and returning the vehicle on 3/14/11.